Re: [Tracker] Database access abstraction

Jamie McCracken wrote:
On Mon, 2008-11-03 at 12:46 +0100, JÃrg Billeter wrote:
On Sat, 2008-11-01 at 01:11 +0000, Martyn Russell wrote:

- tracker_data_query_check_service(), I would probably call that
tracker_data_query_file_exists(). We have this concept of "service"
meaning a file and I really dislike that, but I can understand why we
have a generic word to describe data. For this API, it is specific to
files so I think it would be fine to use "file" instead of "service".
Can't this function also be used e.g. with emails? Then maybe call the
function tracker_data_query_service_exists?

I also dislike the confusion between service, service type, and file,
it's really used inconsistently. I'd just consistently use RDF
terminology to make it easier to understand, but I don't know how other
people would feel about a terminology change, Jamie? In RDF terminology,
we'd have resources (services/entities), classes (service types), and
properties (metadata fields).

only file specific operations should use the name "file"

I agree.

generic ones should use service name so i agree with Juerg here


you can rename Service to ServiceClass or ServiceType if you like

I would rather use something completely different. Like Resource and
Service. Otherwise you end up with these even longer APIs where you have
to have tracker_foo_get_service_class_by_service_type() which isn't as
obvious to me as tracker_foo_get_service_by_resource().


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]