Re: [Tracker] [PATCH] fixing a t-s-t crasher when trackerd is not running

On 8/2/07, Marcus Fritzsch <fritschy googlemail com> wrote:
On 8/2/07, jamie <jamiemcc blueyonder co uk> wrote:
On Wed, 2007-08-01 at 14:07 +0200, Marcus Fritzsch wrote:

there are currently 2 (automatic) bug reports[1,2] for t-s-t, I tried
hard to get it crashing but it did not ;).

Today however, I missed starting trackerd and t-s-t crashed, end the
backtrace at least seems like the ones from those reports.

I added a new function to show a 'general' error and changed
end_search accordingly.

thx thats nice - have added

PS: the odd thing: the error message is like 'Could not execute
/usr/local/bin/trackerd...' - what's odd here: my tracker prefix is
/opt/tracker. also tracker-search prints such a warning, where does
the /usr/local/bin come from? I tried to find it but haven't yet...

tracker-service in /usr/share/dbus-1/services

the file uses the prefix to construct path

suggest doing a make clean and then build with correct prefix so that
dbus can launch trackerd automatically

I am doing distclean+configure to have a valid build tree and install
every time ;)

The funny thing, in that file the trackerd is noted to be in my prefix:

That funny thing happens only on one of my systems - and it is the one
that was broken very badly once... I am prety sure this is an error on
my system.

Cheers, Marcus

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]