Re: [Tracker] [Patch] Tracker deb and libc6 in Debian Etch

Laurent Aguerreche wrote:
Le lundi 30 octobre 2006 Ã 02:01 +0000, Jamie McCracken a Ãcrit :
Laurent Aguerreche wrote:
Le vendredi 27 octobre 2006 Ã 23:01 +0200, Laurent Aguerreche a Ãcrit :

Le jeudi 26 octobre 2006 Ã 17:46 +0200, Tshepang Lekhonkhobe a Ãcrit :
On 10/26/06, Laurent Aguerreche <laurent aguerreche free fr> wrote:
Le jeudi 26 octobre 2006 Ã 16:30 +0200, Tshepang Lekhonkhobe a Ãcrit :

I got damn excited when I read Jamie's proposal for tracker to be
included in GNOME 2.18.
Unfortunately, when installing the deb (in Debian) linked on
gnome-announce-list today, it tells me that it depends on libc6
(>=2.4-1) while Debian is surely going to release with 2.3.6, in
December. Is there a way in which you can accomodate debian users,
without them resorting to compilation?
I'm currently working on these packages :
- add a new package tracker-gnome-search-tool
- some cleanups
Nice stuff.
I send a patch that:
- add a new tracker-gnome-search-tool package;
- remove issues with --rpath  [0];
- add --as-needed for ld to remove unnecessary library dependencies;
- add linda overrides for warnings about wrong "changelog.gz" names. It
happens because Tracker is seen as a native debian package. But it can
be consider that debian packages and releases of Tracker are
independents... so the overrides;
- some cleanups (unnecessary files, backup files still there, etc.)

This patch made tracker-utils and tracker-gnome-search-tool depending
only to libtrackerclient0, not libtrackerclient0 (= 0.5.0). This new
patch fixes it (and it is also cumulative).

thanks have applied to cvs

It did not apply totally clean - can you check from a fresh check out (in a different directory) that its all there

There are still files that are generated during debian package building
and the "rules" file is missing some things.
So I send a patch (and I tested it in spite of building issues. Good
news is that "ioprio support" says "Yes" at configure.  :-) ).

thanks applied but only rules was updated - please let me know if any of the following need adding to cvs in debian folder:

? tracker-utils.substvars
? tracker-utils
? tracker
? tmp
? libtrackerclient0.substvars
? libtrackerclient0.postrm.debhelper
? libtrackerclient0.postinst.debhelper
? libtrackerclient0-dev
? libtrackerclient0

Mr Jamie McCracken

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]