Re: [Tracker] Problems with SSL

Hey there,

On 8/1/06, Jamie McCracken <jamiemcc blueyonder co uk> wrote:
>> hmm.
>> I can suggest the following:
>> 1) check all undefined refs are in ssl.h (/usr/openssl/ssl.h).  (You
>> should have package openssl as well installed)
> It is the case. But it is a problem with MySQL and SSl, not only SSL.
>> 2) If so, check libopenssl.pc (in usr/lib/pkgconfig) it should look
>> something like:
>> prefix=/usr
>> exec_prefix=${prefix}
>> libdir=${exec_prefix}/lib
>> includedir=${prefix}/include
>> Name: OpenSSL
>> Description: Secure Sockets Layer and cryptography libraries and tools
>> Version: 0.9.8a
>> Requires:
>> Libs: -L${libdir} -lssl -lcrypto
>> Libs.private: -ldl -lz
>> Cflags: -I${includedir}
> -lcrypto is in Libs.private on my box, but it doesn't do any difference
> at compilation.
>> 3) if problem still persists, modify to get flags from
>> libssl : PKG_CHECK_MODULES(SSL, [ libssl >= 0.9.6 ])
> ?
> It is already in
>> 4) If all else fails,you can try removing the  ssl stuff from the
>> (lines 90-92 and 98-99) and see if it works.
> I already tried that without any success...
> What parameters do you use at "./configure"?

just --prefix=/usr

> I also tried the tarball of tracker-0.0.4 and get problems with SSL.  I
> always used CVS so I don't know if I would have problems with this
> version before.

sounds like debian unstable is busted at the momemnt

> If you have a Debian Unstable, can you update it and try? I suspect some
> changes from an upgrade this week-end...

I only have dapper and FC5.

Can you report problems to Debian?

Also when I do a release in the next few days I will have a deb for
Dapper which should work on Debian (As we dont use sockets in mysql it
should never call those ssl functions)

I might say, that I am too using a debian sid system --- tracker does
quite well here (but i needed to patch some build-files ;))

Laurent, here's what I have installed and is needed to build/run
tracker (dpkg -l ...):

[pts/3,0,0] m nexus [~] % dpkg -l libc6 libglib2.0-0 libdbus-1-2
libdbus-glib-1-2 shared-mime-info libextractor1c2a libssl-dev
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  libc6          2.3.6-16       GNU C Library: Shared libraries
ii  libdbus-1-2    0.62-4         simple interprocess messaging system
ii  libdbus-glib-1 0.62-4         simple interprocess messaging system (GLib-b
ii  libextractor1c 0.5.14-2       extracts meta-data from files of arbitrary t
ii  libglib2.0-0   2.10.3-3       The GLib library of C routines
ii  libssl-dev     0.9.8b-2       SSL development libraries, header files and
ii  shared-mime-in 0.17-2 shared MIME database and spe

Does that helps? Do you need some more info?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]