[system-tools]users tool on SuSE

Great news on the new list - w00t! :)

Anyway, as some of you will know, I've been working on support for SuSE
in GST (specifically SuSE 9.0 at this stage, will add older versions
once I'm happy with the 9.0 support), but I'm having some problems with
the users tool.

The problem stems from the fact that the default group for a new user on
SuSE is 'users', not $user, but that in /etc/login.defs, users (GID 100)
is significantly lower than GID_MIN (1000), so we have to use

I've changed the code to what I think should do this, but it doesn't.

I'm using a regexp to test if $gst_dist begins with 'suse', but it
doesn't seem to pick it up.  I tested by explicitly testing if $gst_dist
== "suse-9.0", and that worked.  However, it also worked when I randomly
tested it with $gst_dist == "caned-4.7" - ie if I did an explicit test
it returned true no matter what...

The relevant code is in my blog entry at
http://swamprat.homeunix.org/index.cgi/2004/02/26#20040226-4 - if anyone
can look over it, and see something that I've missed, I'd really
appreciate it.

James Ogley, Webmaster, Rubber Turnip james rubberturnip org uk
http://www.rubberturnip.org.uk Jabber: riggwelter myjabber net
Using Free Software since 1994, running GNU/Linux (SuSE 9.0)
GNOME updates for SuSE: http://www.usr-local-bin.org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]