No useful callgraphs on Fedora 27


I would like to use sysprof to analyze some interaction between a poor
performing graphical program and the Xorg x-server.
In the past I remember sysprof worked very well for this kind of
analysis, giving a detailed overview/callgraph which function consumes
how much time and how it was called.

However on fedora 27, despite having all the debuginfo-packages
installed, I don't get a useful callgraph.
Most functions are directly one hirarchy below the Xorg process.

I also gave oprofile a try, with the same result :/

Any ideas what could be wrong with my system?

Thank you in advance & best regards, Clemens

oprofile result:

CPU: AMD64 family15h, speed 4000 MHz (estimated)
Counted CPU_CLK_UNHALTED events (CPU Clocks not Halted) with a unit
mask of 0x00 (No unit mask) count 100000
samples  %        image name               symbol name
167267   37.1351                 fbBltOne
  167267   100.000                 fbBltOne [self]
45871    10.1839             __memcpy_ssse3
  45871    100.000             __memcpy_ssse3 [self]
17944     3.9838  kallsyms                 copy_user_generic_string
  17944    100.000  kallsyms                 copy_user_generic_string [self]

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]