Re: [Shotwell] Help to compile

Found CMake: /usr/bin/cmake (3.16.3)
Run-time dependency libwebpdemux found: NO (tried pkgconfig and
cmake) ERROR: Dependency "libwebpdemux" not found, tried
pkgconfig and cmake

A full log can be found at /home/user/dev/shotwell/build/meson-

Interesting. I'm surprised that it actually compiles.

py-foi elitebook in ~/dev/shotwell

But not work

± |master ✓| → ./shotwell

(shotwell:112301): GLib-GIO-ERROR **: 18:43:57.888: settings object
created with schema 'org.yorba.shotwell.preferences.ui' and path
'/org/yorba/shotwell/profiles/preferences/ui/', but path
'/org/yorba/shotwell/preferences/ui/' is specified by schema

You need to run ninja -C build data/gsettings/gschemas.compiled - this
is missing from the documentation, sorry. I will update them.

More, how I can configure to install in my user folder? 

By default, Shotwell will install under /usr/local.  The configure
      can customize the prefix directory.  Run meson build configure 
      instructions and other installation options.

I test this (
$ meson configure -Dprefix=$HOME/.local/

It should work like this. What issue do you see?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]