Re: [Shotwell] Freezes after a while

Don't background it. If you still want to see the log, tail it in a different term. Look in /var/log (possibly syslog) for any error messages. See if there is still a process for Shotwell running after a freeze. Pure guess, if you haven't got enough memory it may be the OOM killer in action.



On Mon, Jun 17, 2019 at 2:30 AM Dougie Nisbet <dougie katsura uk> wrote:

I'm trying to figure out why shotwell freezes for me. I can't discern a pattern. It can happen after a few minutes or several hours.

I've tried various versions. For a while I was using the basic install from the Debian repos but that does it too. At the moment I'm using 0.30.4.

I've traditionally started shotwell using a wrapper script but I don't know how relevant this is now. Here it is:

dougie@office:~$ cat bin/startshotwell

/home/dougie/shotwell-0.30.4/build/src/shotwell &

tail -f $LOGFILE /home/dougie/.cache/shotwell/shotwell.log

I have a large photo collection. About 107K jpegs. I keep videos separate. There may be some debris in my images folder but I try to ensure that it's just jpegs.

When shotwell freezes there is no activity in the terminal window where I run the wrapper.

Is there a way I could diagnose this better?


shotwell-list mailing list
shotwell-list gnome org

My Amazon author page :

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]