Re: [Shotwell] Shotwell 0.25.0 - program terminated with signal sigsev

Am Dienstag, den 08.11.2016, 17:38 +0100 schrieb Jens Georg:
Am 2016-11-06 17:44, schrieb Hoffmann, Jobst:
Hi Jens,

Am Freitag, den 28.10.2016, 12:07 +0200 schrieb Jens Georg:

I switch over to Fedora 25 Beta and installed shotwell from git.
Compiling worked after installing several additional packages.

If there 's some package missing from the list at (I can
gcr-3) please feel free to update the page (or send me the list so
update it later).

Whenever I start the program, it crashes. So I followed the
to save information about the crash:

SHOTWELL_LOG=1 gdb shotwell 2>&1 | tee shotwell.gdb

I attach the log file and I hope it helps to the error

That seems to be an issue in gst-libav/libav/ffmpeg while trying
parse a media file. Not much shotwell can do about this, though
should think about splitting this off into an process similar to
thumbnailing so a crashing extract doesn't crash the main process.

Can you file a ticket against GStreamer/libav, if possible with
video causing this? The video should be mentioned in 

I'm sorry, but I can't find any name in the log file. I attach the
current log, because I find several things, which could be the
the errors:

Line  7 of the log: Unable to load...
                          This file exists and it is readable!

You can ignore that, the plugin loader is rather stupid and tries to 
load the libtool file.

Line 18 of the log: Failed to create index...

That's not so good but should at max result in a dialog shown to you.

Line 19 of the log: could not load application icon...
                          This shouldn't be a problem, does such an
                          icon exist at all?

Should, but probably doesn't matter.

Line 23 of the log: could not delete mimics
                          What is that for?

Not the faintest idea.

I should mention that most of my pictures reside on a NAS, I use NFS
with an automounter to access the files. 

To see the effect of NFS, I tried to reduce the amount of pictures,
moved a lot of pictures aside, omitted the NFS-files, and built a
photo.db; that worked fine.

After that I added one directory from the NAS and that worked until
about 2000 pictures were in the library.

I hope you can give me some advices how to go on.

Is it always crashing in the video file discovery?

After updating of some gstreamer packages and making the contents of the
~/Video directory invisible (by gzipping - is this the right way?) the
crashs disappeared. I think the issue can be marked as solved.

By the way: can I prevent shotwell from generating .jpeg's from
My standard workflow is
1) viewing the .jpeg's delivered from the camera
2) using a specialized .raw developing program like darktable.

You probably might not want to hear that, but: There's a ticket open
that :)
shotwell-list mailing list
shotwell-list gnome org
Prof. Dr. Jobst Hoffmann            Tel:   +49 (241) 6009-5 31 59
Fachhochschule Aachen Abt. Jülich   Fax:   +49 (241) 6009-5 31 89
Fachbereich 09                      email: j hoffmann fh-aachen de

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]