Re: [Shotwell] Building shotwell on EL7


I looked at that code and they are missing format parameters - They were fixed over the time, so if you really want to use 0.15 (which I would not recommend), you should try and cherry-pick those fixes.

Hi Boris

This is just a guess, but it looks like your valac version is rather
old too (26.1 from a quick search of what's shipped on centos 7), you
could try updating vala first and then try compiling shotwell again
with the more recent valac.


On Jul 17, 2016 21:15, "Boris Goldowsky" <boris alum mit edu> wrote:

I'm having trouble building any recent version of Shotwell on
Scientific Linux 7 (which, for these purposes, is the same as Redhat
Enterprise or CentOS 7).  Shotwell 0.14.1 ships with this OS, but
I'd like to use a more recent version (the main reason is that my
existing photo library was created with 0.15 and won't load with an
earlier version).

I've tried the 0.15, 0.18, 0.23, and latest from Git but had no
success with any of them.

If anyone has advice or is willing to help me get this to work, I'd
very much appreciate it.

For 0.15, here's the result of attempting to build:

./configure && make
Detected libGPhoto 2.5.x - using 2.5-aware code path.
Configured.  Type 'make' to build, 'make install' to install.
[many lines deleted]
valac --target-glib=2.30.0 -g --enable-checking --fatal-warnings
--save-temps --compile --enable-deprecated \
--vapidir=../ --pkg=shotwell-plugin-dev-1.0 --pkg=gobject-2.0
--pkg=glib-2.0 --pkg=gdk-3.0 --pkg=gtk+-3.0 --pkg=gee-0.8
--pkg=gtk+-3.0 --pkg=libsoup-2.4 --pkg=libxml-2.0
--pkg=webkitgtk-3.0 --pkg=gexiv2 --pkg=rest-0.7 --pkg=gee-0.8
--pkg=json-glib-1.0  \
-X -I../.. -X -fPIC \
-X -D_VERSION='"0.15.1"' -X -DGETTEXT_PACKAGE='"shotwell"' \
--vapidir=../../vapi \
../common/Resources.vala shotwell-publishing.vala
FacebookPublishing.vala PicasaPublishing.vala FlickrPublishing.vala
YouTubePublishing.vala PiwigoPublishing.vala
../../src/util/string.vala ../common/RESTSupport.vala
FacebookPublishing.vala:1496.25-1497.108: error: Too many arguments
for specified format
FlickrPublishing.vala:399.33-400.85: error: Too few arguments for
specified format
FlickrPublishing.vala:409.29-410.81: error: Too few arguments for
specified format
Compilation failed: 3 error(s), 0 warning(s)

I tried common-sense fixes for the vala errors, but it still didn't

Any ideas?

Thanks -


shotwell-list mailing list
shotwell-list gnome org
shotwell-list mailing list
shotwell-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]