Compilation Issue

I recently update to Fedora Core 13 (x86=64, from an earlier x86=64 install 
of FC10) and have been having problems with sawfish ever since. When I logged 
in, it was about 50/50 if the window managerr would allow me to do anything 
with the windows - move, select buttons, etc. The windows come up with their 
borders and buttons, but nothing else. This is with a pre-compiled rpm from 
ircam of 1.5.3 There is also the problem that sawfish-ui will not run, 
reporting the problem:

*** File error: No such file or directory, gui/gtk-2/gtk

SO, I decided to try and update to the latest versions of rep and sawfish. 
I7ve compiled and installed (via buildrpm) the following versions:

librep.x86_64                  0.90.6-1.fc13 
librep-debuginfo.x86_64        0.90.6-1.fc13
librep-devel.x86_64            0.90.6-1.fc13
rep-gtk.x86_64                 0.90.3-1.fc13
rep-gtk-debuginfo.x86_64       0.90.3-1.fc13
rep-gtk-devel.x86_64           0.90.3-1.fc13

I downloaded the latest version of sawfish and tried to do an 
rpmbuild on that as well. It fails (in quiet mode) with the same error as 
sawfish-ui for the current installation:

*** File error: No such file or directory, gui/gtk-2/gtk

I:m wondering if this is something odd about a 64-bit compilation, or 
something odd hanging around from earlier installs? I've tried to clean out 
the earlier versions of librep and rep-gtk. When I do a search for 
gui/gtk-2/gtk the following files are reported+


Some very old issues in online fora suggest that rep is looking for its gtk 
libraries in the wrong place, somehow.

If I drill further down into a manual make into the directory:


if I do a make the Warnings which begin to signal the failure (in 
non-quiet mode) of the rpmbuild come from


REP_DL_LOAD_PATH=../../..//src/.libexec REP_GTK_DONT_INITIALIZE=1 
REP_LOAD_PATH=../../../lisp:../../..//lisp rep compiler -f compile-batch 
widget.jl:159: In function `set-widget-enabled':
widget.jl:159: warning: calling undeclared function `gtk-widget-set-sensitive'
widget.jl:159: warning: referencing undeclared free variable 

and many others until the compilation fails. Clearly the system is not 
finding gtk.a/

I get the same problem with 1.6.1, 1.6.2 and 1.6.3

I've been using sawfish forever, and I'd hate to have to abandon it, but at 
present my system is barely usable without proper window control.

Anyone else running FC13 x86_64?

Professor Andrew A Adams                      aaa meiji ac jp
Professor at Graduate School of Business Administration,  and
Deputy Director of the Centre for Business Information Ethics
Meiji University, Tokyo, Japan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]