Re: [PATCH] exit function


On Tue, 24 Nov 2009 18:27:41 +0100, Christopher Roy Bratusek wrote:
> Am Tue, 24 Nov 2009 13:40:45 +0900 (JST)
> schrieb Teika Kazura <teika lavabit com>:
>> * Command group is 'exit sawfish'?

Sorry, I wanted to say (defgroup exit "Exit Sawfish" :group misc).

>> * Func & command 'exit' is so confusing with 'quit'. But what'll be
>>   good? 
> [...] I think that exit is good, because:
> quit = close an application (see "Quit/Close Application" term)
> exit = close the session (see "Exit Session" term)

Who can distinguish the function (quit) which kills sawfish from
(exit)?  (If 'quit' had been named 'raw-quit', then there were no
problem, but we can *never* rename this core function. ;)

> exit-session is not optimal, as it may also be:
> exit-session-and-suspend or exit-session-and-reboot and so on, so we
> need something that is valid for all 5 cases exit may be used for.

But I insist that exit-session will be better than bare 'exit' by the
above reason. (I'm not sure for the word "session". I don't know
exactly how the word "session" is used inside the current Sawfish, and
the common meaning outside of Sawfish, either. Of course it's better
than my "exit-wrapper".)

Teika (Teika kazura)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]