Re: sawfish/gnome-session breakage (solved)

On Tue, 28 Jul 2009, Christopher Roy Bratusek wrote:

> Hmm, I got an idea, what is causing the issue for gnome-session, now
> there I think about:
> gnome-session has changed a lot in the 2.24 cycle, therefore also
> sawfish session-desktop-file changed for gnome-session 2.24. Dunno, but
> perhaps this new file -which works with gnome-session 2.24+- is not
> working with 2.22? Can you try sawfish 1.5, with the .desktop files from
> 1.3? If that is the issue, we will find a way to choose the right file
> in 1.6.

I tried deleting all the sawfish*.desktop files installed by 1.5.0
and reinstalling the sawfish.desktop from  That didn't do
it, but I've found the problem: it's in  In the

 if test "$with_xorg_x11r7" != "no"; then ...

there's no test for X11/SM/SMlib.h.  So HAVE_X11_SM_SMLIB_H never
gets defined, and therefore nothing useful happens in
src/session.c.  The fix is a one-liner:

---	2009-07-28 08:37:14.000000000 -0400
+++	2009-07-28 08:32:06.000000000 -0400
@@ -73,7 +73,7 @@

 if test "$with_xorg_x11r7" != "no"; then

-AC_CHECK_HEADERS(X11/extensions/Xdbe.h, [], [], [#include <X11/Xlib.h> ])
+AC_CHECK_HEADERS(X11/SM/SMlib.h X11/extensions/Xdbe.h, [], [], [#include <X11/Xlib.h> ])

 dnl Checks for X extensions/libraries

Allin Cottrell

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]