Re: on viewport; doc review request & questions

Thanks Jeremy for the patch. I worked a bit more on doc.

On Tue, 24 Nov 2009 08:28:43 -0600, Jeremy Hankins wrote:
> But we should obviously get rid of either window-relative-position
> or window-absolute-position.

I noticed they're not exactly the same. window-absolute-position
returns the adjusted position only if it's completely outside of
the current VP, but window-relative-position always uses
the window-viewport.

They have to be united into one, perhaps using an optional arg, but I
don't know exactly what this difference means. Is it possible for you
to complete it?

> But what should the name be? To my mind
> window-absolute-position seems like a very strange and non-intuitive
> name for something that gives the position of a window relative to the
> vp it occupies, but what do others think?

I don't feel like another "incompatible change" notice (since
there remain tasks, many for me, for 1.6 release). But
my best candidate is "window-position-in-viewport"
>>>> I've renamed viewport-offset to viewport-offset-pixel.
> [...] 
> I disagree. [...]

Ok, then I'll change it to "viewport-offset-coord". Anyway the
suffix is necessary, and "pixel" in doc will suffice.

(In fact, when I browsed viewport.jl before, I couldn't tell if
the warp-viewport's args are pixels or vp slot indices even though
it is written "coordinates" in the doc-string. So "pixel" in doc
is needed.)

By the way, I've noticed one more confusing factor in VP.
I think your explanation "think of vp as a hole" is correct.
But the word "vp" is used also for the vp cell. It's sometimes
useful, like "go to the next vp", rather than "move the vp to
the next slot", but you have to be aware that it's an extended use.
(So, "the viewport" is ok, but viewport"s" means you have two
heads or 4 eyes. ::-)

Teika (Teika kazura)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]