Inoperable right-mouse button in OpenOffice 2.0.1


I am using Gnome desktop and sawfish window manager (Gentoo Linux on a x86 laptop).  If I set the focus to follow the cursor on when entering and exiting a window, I can't get the right mouse button to work inside an OpenOffice 2.0.1 application.  I just found a workaround, which is that If I set the focus to be affected only when the mouse pointer enters a window, the right mouse button seems to work fine.  I didn't have this problem with previous versions (1.x) of OpenOffice.

If I use some other window manager, the right mouse button works fine in an OpenOffice application.  I've tried icewm, fvwm, and mwm, and they all work fine, but I prefer sawfish with the focus following the mouse pointer on both entering and exiting a window (I can live with the workaround, if I have to).

I've tried the same thing on an AMD64 desktop (Gentoo linux, gnome, sawfish), and the right mouse button works fine in openoffice apps.

Has anyone else seen this behavior with sawfish and OpenOffice 2.0.1 on x86 systems?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]