Mac OS X cut and paste


I am currently running Mac OS X 10.3.4 with their X11 version 1.0. I pulled down a recompiled version of sawfish from fink. It is version 1.1-26. I am currently pulling down and compiling from fink sawfish 1.3-17.

My question is about cut and paste from an X11 window to a native Mac application. If I use Apple's quartz-wm, the process of cutting from X11 and pasting to a native application is to select the text using normal X11 mouse techniques, then pick Cut from the edit menu of Apple's X11 application. At that point I can paste the text into any native Mac window using Comnand-V. To go the other direction is even simpler. I simply cut (or copy) using Command-C and then paste into the X11 with the normal technique (^Y for emacs, button 2 for xterm, etc)

If I kill quartz-wm and start up sawfish, I can no longer to this. I also tried mwm running from an AIX platform and it had the same problem.

Before posting this note, I looked to see if this was mentioned anywhere -- perhaps, I thought, sawfish 1.3 has already solved this problem but I could not find any reference to it.

So I was just checking the email list to see if this topic has come up before. Is anyone working on this? Is it a solvable problem? etc.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]