Re: Rygel errors while running CTT


On 10/19/2010 04:17 PM, Zeeshan Ali (Khattak) wrote:

On Tue, Oct 19, 2010 at 3:19 PM, Alper Guler<aguler ubicom com>  wrote:

On 10/19/2010 02:50 PM, Zeeshan Ali (Khattak) wrote:
Hi Alper,

On Tue, Oct 19, 2010 at 12:06 PM, Alper Guler<aguler ubicom com>    wrote:

Hi Zeeshan,

I upgraded to 0.8.2, but got an error while running CTT (specifically as below. I had not got any errors while running 0.9.0. Can
be because you have not picked up commit
a838088559a27ec5488e89fac4cff0b2dd3b651a? Or what can it be about?

    Firstly, What happened to you posting to ml rather than me (only) ?
I think your question will better be answered by Jens and now that he
can see your mail, I'm sure he'll reply. :)

You give very quick response. Maybe that is why :-) Anyway, let me post to
ml from now on.

Well, in the meantime I tried after applying "commit
a838088559a27ec5488e89fac4cff0b2dd3b651a" myself, but it did not work. Then
I checked my results with 0.9.0 and found out that test has stopped in this
test case ( and then I have restarted it. I guess I had thought the
problem was about my system due to low memory then (I am having memory
problem on my board with 64 MB) and therefore I had not thought of this as
rygel`s bug, but now I know it is not about rygel stopping to run due to low
memory. There is a different problem in this case and it exists in 0.9.0,
too. Have you ever seen this problem?

The interesting thing is that when I ran only this test case after starting
rygel with the sqlite patch, it did not give this error. So, I thought this
patch has fixed it, but then I started the CTT tests from scratch and I got
the same error again when it came to this test case. Another thing to note
is that when I start Rygel again right after seeing this error, test passes and I don`t see this error again.

Any ideas?
    My hunch is that there is some leak(s) in rygel (or deps) and the
memory usage grows when you run different tests so by the time the
said test is reached, there isn't any memory left and then weird
things happen.
Actually, I ran the latest test on a board with 256 MB RAM, so it should not be about memory, but let me check the memory status when the failure occurs just in case.

    BTW, You seem to be having a very special use-case for rygel and
I'm afraid you'll have to dive a bit deeper into the rygel (source)
and gupnp as a hacker to be able to succeed in what you are trying to
accomplish. We'll try our best to help out of course but that might
not be enough.

Right. I just don`t want to waste time on issues you have already fixed or can easily fix. Other than that, I know that I will have to dive into the source code.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]