Re: [Rhythmbox-devel] Troubling building and running rb from svn

Thanks. Using that configure flag allowed it to work properly. I still
get those make warnings, but things appear to be working fine. Any
suggestion on fixing my system so those make warnings don't appear.
Are other people building and developing under fc6?


On 3/11/07, James Doc Livingston <doclivingston gmail com> wrote:
On Sat, 2007-03-10 at 14:50 -0500, Jon Dufresne wrote:
> I am trying to compile and run rb from gnome svn. I can successfully
> make it, but it does not appear to work properly when I run it. I am
> compiling under fc6. When I make I get the following warnings:
> ../../libtool: line 6823: LC_ALL: command not found
> ../../libtool: line 6823: LC_CTYPE: command not found
> ../../libtool: line 6823: LC_COLLATE: command not found
> ../../libtool: line 6823: LC_MESSAGES: command not found

These look odd and I'm not sure exactly what would cause them, but if
everything builds fine, it might be okay.

> After it makes when I run it I get the following warnings
> ------
> $ ./rhythmbox
> Is this something that I'm doing wrong or a bug in rb? This is using
> svn revision 4925.

If you want to run Rhythmbox from inside the source tree, you need to
pass --enable-uninstalled-build to This tells it
to look in the current directory for it's data files.

We should probably print out a message when you try to run it like that.


James "Doc" Livingston
I have hardly ever known a mathematician who was capable of reasoning.
    -- Plato

rhythmbox-devel mailing list
rhythmbox-devel gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]