[Rhythmbox-devel] Re: Problems after initial compilation

> Now rhythmbox starts OK, it recognizes my MP3 files (it complains about
> "Internal GStreamer error: negotiation problem." for each .m4a file)
> but it refuses to play them.  when I try to play an MP3 file, I get two
> popup boxes.  The first one says "Internal GStreamer error: pad problem."
> the second says "Internal GStreamer error: negotiation problem".

> I tried:

>    gst-launch filesrc="foo.mp3" ! mad ! osssink

> and it works OK, so some part of my setup is not completely botched.  I have
> compiled gstreamer myself (this is a Fedora Core 2 machine with gstreamer
> 0.8.3 where I compiled gstreamer-0.8.9 and gst-plugins-0.8.8 by hand 'cause
> I don't have root access and my previous attempts to add MP3 support to the
> built-in gstreamer failed).

It turns out that the problem also appears for Ogg files and that it is just
another manifestation of the problem I had originally (which caused me to
try and compile my own) where I got a message like "can't pause".

I just needed to do:

gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string "alsasink device=hw:0"

and now I can finally play my Ogg and MP3 files on my work machine just
fine.  MP4 is still not working, but I can reproduce the problem
without Rhythmbox, so it seems to be a gstreamer problem.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]