Re: Announcement/RFC: jhbuild continuous integration testing

Hello again,

first, thanks for everyone who jumped in and helped to fix failures! I
wanted to send a quick update.

Martin Pitt [2013-02-12  7:43 +0100]:
 - colord: recently started depending on libsystemd-login, which we
   don't have yet; that's a fault on the Ubuntu side

I installed the libsystemd-login libs and pushed a fix for a missing
library link to trunk. Working now.

 - e-d-s: calls an undeclared g_cond_timed_wait(), not sure what this
   is about

I filed a bug, Matthew Barnes quickly fixed it in trunk. After that it
was working for two runs. (Not any more, see below)

 - folks: this started failing very recently, and thus is a perfect
   example why this is useful (unqualified ambiguous usage of

Philip quickly fixed that one, working now.

 - gst-plugins-bad: unknown type GStaticRecMutex; this might be due to
   recent changes in streamer? That smells like a case of "broken by
   change in dependency, needs updating to new API"

Still outstanding.

 - mutter: worked until Jan 7, now failing on unknown XIBarrierEvent;
   that might be a fault in Ubuntu's packages or upstream, I
   haven't investigated this yet

Jasper pointed out the problem in Ubuntu'x libxi packages, I'll take
care of this.

Test failures:
 - gst-plugins-good, empathy: one test failure, the other tests work

gst-plugins-good got fixed by Tim, empathy still outstanding.

 - realmd: This looks like the test suite is making some assumptions
   about the environment which aren't true in a headless server?
 - webkit: I don't actually see an error in the log; we'll investigate
   this closer on our side

Still outstanding.

So yesterday evening we were down to 5 failures, but over night we got
a swath of new test failures. Wading through them now, but some look
quite nonobvious. 

nautilus failed on

      evaluated: nautilus_file_get_name (file_1)
      expected: eazel:///
      got: eazel:

It failed on exactly that until January 5, then was working until
yesterday, and now failing again. For such issues I'd be glad if one
of the nautilus maintainers could work this out with me.

libgdata once again failed on the youtube test, as it did in the past.
In general, any test that tries to access remote servers is pretty
much doomed on that machine I'm afraid, as it can only do http and
https through a proxy (it has $http{,s}_proxy set).

I'll look at the other failures now.

Martin Pitt                        |
Ubuntu Developer (  | Debian Developer  (

Attachment: signature.asc
Description: Digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]