Bumping/Dropping the PolicyKit external dep

David hinted at this some weeks ago, but I think we need to come to an
explicit decision on this topic:

PolicyKit 1.0 is going to be released sometime soon; the current 0.92
release should have the final API already. Currently, we have an
external dep on PolicyKit 0.9 (and PolicyKit-gnome). The 0.9 branch of
PolicyKit is not going to see further development; it is effectively
dead already.

We should make a decision to bump our PolicyKit dependency to 0.92 for
Gnome 2.28. Curiously, this effectively drops PolicyKit as an external
dependency (except for the few mechanisms that are included in Gnome
modules, such as the GConf defaults mechanism).

Richard and I have produced patches to port all affected Gnome
modules, which can be found in bugzilla, or, more conveniently, here:


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]