Re: ERROR:root:Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

On Wed, Nov 17, 2010 at 12:54 PM, John Palmieri <johnp redhat com> wrote:
> Oh, ya, Fedora 14 ships with a really old version of PyGObject Introspection.  You are not going to see a newer version until Fedora 15.  This is because the GObject Introspection ABI changed after the freeze.  This is the price of playing on the cutting edge.  I suggest running rawhide in a virtual host or using jhbuild to build a buildroot.  We are committed to stabilizing introspection in the next 5 months (well we freeze in 2 to 3 months).   Until then there is going to be pain like this.

Ok, so realistically, what are my options here? I would ideally like
for users of Fedora 14 to be able to install and run my app (the goal
of my app is to be useful to users, not just some toy that only works
for cutting edge developers). I guess introspection was a premature
choice for achieving that goal, but it seemed kinda pointless to
develop against obsolete technology.

If I install pygobject from rawhide, would it be reasonable to provide
instructions for users to also do that, or should I basically just
give up on the idea of having any users until Fedora 15?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]