Re: [orca-list] Issues using input methods in Orca (forwarded message)

Replied privately before seeing this here. But from the debug output it
seems like the input method is inaccessible (no accessibility events
other than key presses and releases).


On Mon, 2021-09-20 at 11:06 +0200, Didier Spaier via orca-list wrote:

per her request I am forwarding two issues reported by Aiyumi Moriya
CC) who is not subscribed to this list in two emails.

For your information, Aiyumi was I think the first person having
and used Orca in Slackware and helped me include it in Slint.

First issue forwarded below:

I'm having two problems with Orca. I'm using Orca 41.rc in Slint (an
accessible Linux distribution based on Slackware), but the problems
happened in Orca 40 as well:

1. I'm trying to write in Japanese (I use Orca with the Voxin TTS
which speaks in Japanese). I tried three different input method
frameworks: SCIM, IBus and Fcitx. The three of them work with both
and QT applications (though I only tried them with GTK), and all of
them have the exact same problem. Even though their configuration
tools are accessible (made with GTK) and I was able to configure the
input methods and get them to start, the actual character input part
isn't accessible. When I write text and try to input Japanese
characters, I press the shortcut to turn the input method on (usually
"Control" + "Space") then begin typing, Orca doesn't read what
characters are being entered. Also, when there are different
characters that have the same pronunciation, the input methods show a
list from where I'd have to pick the character that I want, but Orca
doesn't read the list, either, and all I can do is try to get the
right characters by trial and error. I wonder if these input method
frameworks use an inaccessible GTK widget for the character entry
component, or if it's not even GTK at all. I hope it's GTK and Orca

Hopefully these problems can be solved from the Orca side.

Thank you!

(then in a second message - Didier)

1. I activated Orca's debug option and went to an empty text document
in Pluma (I didn't even change the TTS to the Japanese voice since
just type random things). I pressed "Control" + "Space" to activate
the input method. From there, Orca echoes the keys I press but
say the Japanese characters that appear. I typed "kita" then pressed
"Tab" to bring up the list of characters to choose from, then pressed
"Enter" to pick the first choice (even though I don't know what it
because Orca didn't read it). Only then, back to the text document
not in the input method window anymore, Orca read the text that was
inputted. I'm sending the debug file.

(I will send the debug file to Joanie - Didier)

(answer to my question about the desktop she uses below - Didier)

I'm using Fluxbox and everything else with GTK is working normally. I
also doubt that switching to another desktop environment would change
anything. Years ago when I was still on Slackware, when I tried the
input method thing for the first time, I had been using XFCE and the
result was exactly the same.
orca-list mailing list
orca-list gnome org
Orca wiki:
Orca documentation:
GNOME Universal Access guide:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]