Re: [orca-list] Orca 3 and Firefox

I don't recall how to switch back to CORBA, should that be necessary.
I agree though; it is best to stick to the latest stuff if possible
since that will be the norm and it does need testing/evaluation/fixing
and all that.  I wonder if the DBUS bugs you are encountering is what
is breaking the structural navigation in Orca?

On 5/5/11, Michael Whapples <mwhapples aim com> wrote:
I have just tried at-spi on corba and compared it to at-spi on dbus. The
dbus does seem to cause some of the issues noticed. The one I really
tested was the one where I cannot cursor from one frame to another,
corba allows me to cursor but the dbus at-spi requires me to tab into
the next frame.

Michael Whapples
On 05/05/11 22:03, Steve Holmes wrote:
Hi, I am at work right now so can't play with the  setup right now but
I was using FF 4.0 quite happily before the gnome3/ Orca 3 upgrades
yesterday.  So that's why I point the finger as I do here.  I concur
with Michael's observations with HTML pages.  I was on this morning and had an awful time when the page
loaded and my attempts to use struct. Nav. to find the login button
and to find tables. I would suggest, go to any page with some markup
like headers and tables and try using the nav commands to jump around
the pages.  I haven't installed a git version of Orca 3 yet in case
that makes a difference.  I will probably upgrade the orca-git package
in AUR this evening so it will pull the latest orca-3-0 branch and see
if that makes any difference.  I suppose there could be some other
gnome related package that broke this nav stuff but I would have no
idea how to pin that down, were that the case.

On 5/5/11, Michael Whapples<mwhapples aim com>  wrote:
I have noticed some changes as well since upgrading to orca 3.0.1.

* Firstly it seems like the page may not properly be focused when the
page loads, odd things happen here (either cursoring doesn't happen or I
get jumped to the bottom of the page).
* Possibly related to the first there seems to be some pages where
pressing down cursor seems to have the cursor somewhere along the line
(eg. may be at the right hand end of the line).
* Orca does not seem to easily navigate from frame to frames of pages
(IE. I certainly cannot just cursor into the next frame). An example of
this is a document (any document seems to hold for this) I have
converted from PDF to html using pdftohtml has a frame with links for
each page and a frame with the page content. I cannot just cursor from
the links frame to the content frame. Also if I press control+end in the
links frame I just go to the end of the frame. To get to the content
frame I must press tab from the last link in the links frame.

If you do file bugs let me know if you include any of these.

Michael Whapples
On 01/-10/37 20:59, Steve Holmes wrote:
I'm not sure what broke here but structural navigation with Firefox 4
plus Orca 3.01 is a mess.  I couldn't navigate to tables nore could I
navigate within the cells of a known table.  This all worked good with
Orca prior to #3.

Does anyone have further comments on this? Otherwise, I may have to
start opening up a bunch of new bugs against Orca 3.

orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at
The FAQ is at
Netiquette Guidelines are at
Log bugs and feature requests at
Find out how to help at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]