Re: [orca-list] Accerciser 1.9.3 Breaks under Python 2.7!!!

Well there definitely seems to be some fall out from changing to
python 2.7.  I applied a quick change to the environment that was
supposed to make the build stuff use python 2.7.  Well that worked at
build time but when I ran it I got the fore-mentioned trace back.  I
since found a line in the accerciser startup script which still points
to the wrong version of python.  I temperarily changed the python to
python2 in the 
#!/usr/bin/env python
line and that got the program going.  I need to look further at the
whole scene here to be sure there aren't other gochas aaround here
with this.  I notice Arch has a python27 patch they are applying to
pygtk package so I'll continue on this quest.

On Sun, Oct 24, 2010 at 08:59:52AM -0700, Steve Holmes wrote:
I just rebuilt the accerciser 1.9.3 package in my Arch Linux system
yesterday and now I get a trace back! Recent changes to Arch involved
migrating all Python 2.6 functions to Python 2.7 and version 3.1 is
now available as the new platform.  I set up my package build script
to reference python 2.7 modules; it builds fine but when I go to
execute the main accerciser program now, all I can get is this
traceback which I will insert below.  When looking at the dump, I
can't see which package is actually amiss.  

Can anyone help out here.  Without fixing this, I cannot do any real
debugging of Orca! The git version appears to be completely intended
for the new stuff so I doubt I would be able to use it here yet.

Script started on Sun 24 Oct 2010 08:44:47 AM MST
steve lnx3:~$ accerciser
Traceback (most recent call last):
  File "/usr/bin/accerciser", line 31, in <module>
    import gnome
  File "/usr/lib/python2.7/site-packages/gtk-2.0/gnome/", line 10, in <module>
    import gobject
  File "/usr/lib/python2.7/site-packages/gtk-2.0/gobject/", line 26, in <module>
    from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
  File "/usr/lib/python2.7/site-packages/gtk-2.0/glib/", line 22, in <module>
    from glib._glib import *
ImportError: /usr/lib/ undefined symbol: _Py_ZeroStruct
steve lnx3:~$ exit

Script done on Sun 24 Oct 2010 08:45:11 AM MST

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]