Re: [orca-list] development branch of orca and gnome-2.24 on fedora core 10
- From: Willie Walker <William Walker Sun COM>
- To: peter rayner lsce ipsl fr
- Cc: orca-list gnome org
- Subject: Re: [orca-list] development branch of orca and gnome-2.24 on fedora core 10
- Date: Wed, 05 Aug 2009 08:20:37 -0400
The configure.in file has indeed changed. The following threads posted
the other day may be of help, though they are related to Ubuntu:
I'm not sure how the Fedora folks have packaged gnome-python-desktop-2.0.
> Requested 'libspi-1.0 > 1.24.0' but version of libspi is 1.24.0
Eeks! I meant to make this ">=" instead of just ">". I just checked in
a fix for that. With this fix, you should be able to
compile/install/run Orca from git on a GNOME 2.24 system. Note that the
official word is that Orca is meant to be compatible with the version of
GNOME that it ships with. So, for example, Orca's git master is being
developed for the GNOME 2.27.x development releases, which will become
the 2.28.x stable releases.
If you are having success on an earlier version of GNOME, then you can
comment out or delete the following lines in your configure.in file to
eliminate the errors:
dbus-python >= 0.83.0 \
gnome-python-desktop-2.0 >= 2.24.0 \
libspi-1.0 >= 1.24.0 \
Peter Rayner wrote:
I have recently upgraded to FC-10 and consequently started looking at
gnome etc again. As part of this I grabbed the development versions
of orca, at-spi and atk from the git repo.
When I last did this (a couple of weeks ago) this seemed to work.
Yesterday, after pulling the latest revisions, it didn't. Here's the
end of the configure output:
checking for orca... configure: error: Package requirements ( dbus-python >= 0.83.0
gnome-python-desktop-2.0 >= 2.24.0 libspi-1.0 > 1.24.0 ) were not met:
Requested 'gnome-python-desktop-2.0 >= 2.24.0' but version of GNOME-python is 2.23.0
Requested 'libspi-1.0 > 1.24.0' but version of libspi is 1.24.0
This seems clear and suggests to me that I probably can't keep
following the development version without instaling gnome-2.26. If
that's right I won't invest the effort to fix the problem. Can
someone confirm that these dependencies have, indeed, changed?
] [Thread Prev