Re: [orca-list] problems with Orca when I upgraded at-spi

Hi all.

I haven't had time to research this *at all*, but the following has
worked on two of my affected Ubuntu machines:

1. sudo apt-get remove at-spi

This caused several packages depending on at-spi to also be removed.
Note them down "just in case".

2. Checked out and built both atk and at-spi from svn trunk (being sure
to specify the right value for libexecdir -- see the Orca wiki).

3. Reinstalled Orca from svn trunk, along with Accerciser which was
another of my victims from step 1.

4. Logged out and back on.

Firefox is now officially claiming to be part of the Gecko toolkit
again. Yea!


1. Since I don't know yet what was broken, I don't know what exactly in
the above was the fix.

2. Since I don't know yet what was broken, I make no promises that your
following the above steps will a) fix things for you or b) not make
things worse.

3. My Intrepid boxes now think that at-spi and accerciser aren't
installed and presumably won't update them in the future. Based on
today, that might be a good thing <smile>; then again, it might not.

In other words, I might be tempted to wait and see what Luke (and/or
anyone else knowledgeable from the Ubuntu a11y community) has to say. Or
at least wait until more guinea pigs have tried to salvage things and
succeeded before I risked a system upon which I depended.

Good luck. And if you learn anything one way or another, please share it
here. Thanks!

Take care.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]