Re: [orca-list] More Building Woes

Hash: RIPEMD160

I do have gnome-common installed.  However, I just uninstalled it and
rebuilt it with --prefix=/usr.  I figured perhaps the /usr/local/usr
default was the problem.  And I just saw another message on here
hinting that possibility.  So I did that and re-installed it; at-spi
configures ok but now I get a bunch of unresolved external references
so the make is failing big time!  I never did get atk bo build right
and it still won't even after the rebuild of gnome-common.  I wonder
if it has to be --prefix=/usr too?  

Maybe I better rip out gail and re do that one as well.  I was
somewhat concerned about overlapping preinstalled packages with stuff
from svn or tar balls so that's why I was hoping to use /usr/local in
case I had to fall back to base line code.  I sure don't wanna have to
completely rebuild my system if this comes appart.  That would be too
much like Windows!!!

On Fri, Jan 25, 2008 at 12:00:41PM -0500, Willie Walker wrote:
Hi Steve:

It looks like you might not have gnome-common installed.


Steve Holmes wrote:
Hash: RIPEMD160

When attempting to build latest at-spi from svn, I get the following
messages and config stops dead in its tracks.  It claims it can't find
gnome-common.m4.  Well, I installed gnome-common yesterday with a
prefix of /usr/local by default.  I checked and the gnome-common.m4
does exist under /usr/local/share/aclocal...  As you will see below,
the script suggests altering my ACLOCAL flag? I don't know where that
is nor I really know anything about aclocal, pkgconfig or any of that
now <sigh>.  Can anyone help out? 
- ----- Begin log -----
Script started on Fri 25 Jan 2008 09:41:40 AM MST
steve lnx3:~/svn/at-spi$ ./ --prefix=/usr 
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
 testing autoconf... found 2.61
checking for automake >= 1.9...
  testing automake-1.10... not found.
 testing automake-1.9... found 1.9.6
checking for libtool >= 1.4.3...
  testing libtoolize... found 1.5.24
checking for glib-gettext >= 2.2.0...
  testing glib-gettextize... found 2.14.4
checking for intltool >= 0.25...
  testing intltoolize... found 0.36.3
checking for pkg-config >= 0.14.0...
  testing pkg-config... found 0.21
checking for gtk-doc >= 1.0...
  testing gtkdocize... found 1.8
Checking for required M4 macros...
  gnome-common.m4 not found
 gnome-compiler-flags.m4 not found
***Error***: some autoconf macros required to build at-spi
 were not found in your aclocal path, or some forbidden
 macros were found.  Perhaps you need to adjust your

steve lnx3:~/svn/at-spi$ exit

Script done on Fri 25 Jan 2008 09:42:18 AM MST
- ----- End Log -----

- -- 
HolmesGrown Solutions
The best solutions for the best price!
Version: GnuPG v1.4.7 (GNU/Linux)

Orca-list mailing list
Orca-list gnome org
Visit for more information on Orca

- -- 
HolmesGrown Solutions
The best solutions for the best price!
Version: GnuPG v1.4.7 (GNU/Linux)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]