Re: Orca Building gnome-speech driver for eSpeak

Awesome, that does it! Thanks so much Will!!

Willie Walker wrote:

If you are willing to experiment, try adding a -lm to the swift_LIBS line in gnome-speech's, then redo the autogen and rebuild. I wonder if it will work:

 swift_LIBS="-L$with_swift_dir/lib -lswift -lm"


Mike Pedersen wrote:
Works for me. :-( Looks like some sort of math library might have gotten screwed somehow.

I just tried this on feisty and am getting the same errors.  Mike

Joanmarie Diggs wrote:
Hi Will.

Any chance that something has changed in gnome-speech that
might cause
it to no longer build? The reason I ask is that I tried to install eSpeak on my laptop, but building gnome-speech consistently
the following error w.r.t. swift:

/opt/swift/lib/ undefined reference to `exp'
/opt/swift/lib/ undefined reference to `sin'
/opt/swift/lib/ undefined reference to `pow'
/opt/swift/lib/ undefined reference to `cos'
collect2: ld returned 1 exit status
make[3]: *** [swift-synthesis-driver] Error 1

So just now I tried updating and rebuilding gnome-speech on another
computer and got the same results. Any suggestions?

Thanks in advance!

Orca-list mailing list
Orca-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]