ODP: cannot connect rtl8192fs to wireless network using NetworkManager with wpa_supplicant

Hi Beniamino,
thx for your quick response, I'll try to pass these NM parameters, as you suggested and see if it works. Btw. they do differ than these from wpa_supplicant, so maybe there is the problem. I will keep you inform.

Best regards

Od: Beniamino Galvani
Wysłano: Wtorek, 26 Styczeń 2021 14:03
Do: Piotr Lobacz
DW: networkmanager-list gnome org
Temat: Re: cannot connect rtl8192fs to wireless network using NetworkManager with wpa_supplicant

On Sun, Jan 24, 2021 at 02:32:01PM +0000, Piotr Lobacz wrote:
> i am struggling for a week to connect via NM together with
> wpa_supplicant using systemd on buildroot. I have compiled
> wpa_supplicant with dbus support. Before that i tried to use only
> NM, but the nmcli was saying that the wlan0 interface was
> unavailable. I was unable even to scan network using nmcli, but
> iwlist wlan0 scan command was working just great. More over if i use
> only wpa_supplicant configuration file with this command:
> [...]

> There is one more thing. This rtl8192fs driver needs private
> parameters to work. Before i call wpa_supplicant command i need to
> call this 4 commands:
> [...]

> But the connection isn't being established. I have attached logs
> from wpa_supplicant and NetworkManager.

> Btw. i have also tried to establish connection setting this iwpriv
> parameters on wlan0 interface but for some reason these are not
> working for wpa_supplicant/NetworkManager. I was wondering if NM
> somehow passes it's own configuration to the interface? If yes how
> can make some modifications?

Yes, NetworkManager passes its own configuration to wpa_supplicant via
D-Bus. You should be able to see the configuration in NM logs; on my
machine for example I see:

 NetworkManager[1645]: <info>  [1611663864.0215] Config: added 'ssid' value 'home'
 NetworkManager[1645]: <info>  [1611663864.0215] Config: added 'scan_ssid' value '1'
 NetworkManager[1645]: <info>  [1611663864.0215] Config: added 'bgscan' value 'simple:30:-70:86400'
 NetworkManager[1645]: <info>  [1611663864.0215] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK'
 NetworkManager[1645]: <info>  [1611663864.0215] Config: added 'auth_alg' value 'OPEN'
 NetworkManager[1645]: <info>  [1611663864.0215] Config: added 'psk' value '<hidden>'

You could try to see if the same configuration works with
wpa_supplicant alone.

Regarding iwpriv parameters, NM doesn't support them. But if you set
them manually before connecting with NM, I guess they should work.


Softgent Sp. z o.o., Budowlanych 31d, 80-298 Gdansk, POLAND

KRS: 0000674406, NIP: 9581679801, REGON: 367090912


Sąd Rejonowy Gdańsk-Północ w Gdańsku, VII Wydział Gospodarczy Krajowego Rejestru Sądowego

KRS 0000674406, Kapitał zakładowy: 25 000,00 zł wpłacony w całości.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]