Re: Doesn't reconnect to wifi after resuming from suspend

Dan Williams wrote:

On Tue, 2015-02-03 at 23:15 +0100, Ferry Toth wrote:
On my home wifi network I have 1 2.4GHz and 1 5GHz AP (is actually 1
fritz box).

With one machine (chromebook running kubuntu 14.10 and AR9462 abgn wifi)

When automatically reconnecting to 5GHz after resume half of the time the
connection fails and retries indefinitely. It seems to fail more when
moving the laptop to another location in house while it sleeps (so the
list of visible networks actually changes).

When this happens it is almost impossible to reconnect manually.

(what works sometimes is disconnecting the connection that is building,
disable the wifi, enable again, wait a bit then manually connect to the
other (2.4GHz) AP)

Strangely: disabling autoconnect on resume and then manually connecting
always works.

Other strange thing: Another machine (NUC with intel wifi and same
kubuntu 14.10) always works.

To me, it seems to be some interference between rescanning and

I have no idea what is the difference in the state machine when
autoconnecting vs. manual.

I've provided log's on bugzilla

I updated the bug with some thoughts after looking at the logs.  It
looks to me like the issues are exclusively driver and/or supplicant
problems.  In the failed automatic log, the access point and the device
don't agree on state, so the access point rejects the device.  That
starts a reconnect attempt which then apparently fails at the driver
level because the AP never responds to teh driver's association
attempts.  Later on, the supplicant enters the scanning state but has to
time that out because the driver never notifies the supplicant that the
scan has finished.  Even later, the supplicant screws up by trying to
associate with 00:00:00:00:00:00 and then it simply falls over.

One thing you could do is try to set up a resume-time script that just
does 'rmmod ath9k; modprobe ath9k' and see if that fixes most of your
issues; if so then it's usually an indication of driver bugs.  Given
that iwlwifi works fine on the machine, I think the issues are specific
to the ath9k driver, and not the mac80211 stack (which iwlwifi also


Thanks Dan,

Yes I already tried al that before reporting the bug. That's what some 
report (google) worked for them. First I thought it worked for me too. But 
alas, after these wakeup scripts automaically reconnect works sometimes, 
sometimes not, same as now,

I agree it must have something to do with the driver, as the Intel always 

AND the same network manager (in Kubuntu 14.04) worked well, while in 14.10 
not. To me it seems in 14.04 it also connected faster, so fast that when I 
opened the lid and passed the screen saver password I would be already 
connected (< 3 sec).

OTOH NM state machine seems to get confused and does not recover. While when  
manually connect it always works.

So it seems the code path on autoreconnect is different, or there is a bug 
in the state machine that only pops up immediately after resume.

But you have a point: could it be the ath9k never notifies that the scan is 

Would that be after a certain kernel? But I used 14.04 with kernel 3.17 (no 
problem) and 14.10 with 3.17 (and now 3.18)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]