Re: Network Manager crashes after a configuration is added and a connection is attempted.

On Wed, 2014-07-02 at 09:41 -0600, Chris Hessing wrote:
On 7/2/2014 7:43 AM, Dan Williams wrote:
On Wed, 2014-07-02 at 11:26 +0200, Thomas Haller wrote:
On Tue, 2014-07-01 at 16:52 -0600, Chris Hessing wrote:
Hi all,
I thought it might be an issue with the variant type I was sending in to
some configuration setting that was later being parsed when I requested
the connection become active.   However, after going through my code to
generate the settings, they all match what is documented here :

One interesting tidbit is that after Network Manager crashes, and is
restarted by the system, the connection comes up fine and seems to work
from then on.

At this point, short of cracking open the Network Manager code, I am
running out of ideas as to what it could be.   Perhaps someone that
understands the Network Manager code can shed some light on what might
be going on?
Hi Chris,

This looks like a bug in NetworkManager.

The attached patch should fix it.
Patch looks right to me.  It's likely unnoticed because these days most
certificates use the "path" scheme instead of the blob scheme, and thus
this code doesn't get triggered.

 says that we cannot pass a GByteArray instead of the expected GArray of uchar. But I think the comment 
is just wrong, because a GByteArray *is* actually a GArray.
We should look at this a bit more; I ran into this when doing the
wwan-ipv6 stuff and it did cause a crash that was fixed by using GArray
instead of GByteArray.  But we've been using GByteArray for a really
long time, so I'm sure that at some point in the past this worked.


Hi guys,

Thanks for the patch and the info.   I'll look in to changing my code to 
use the path method instead of the blob method.   I know I used the path 
method in the past, but there was some issue I ran in to that made me 
move to the blob method.    As I move back toward the path method I'll 
update you guys if I happen to trigger or remember why I went that way.

Thanks again for the info!


I opened Fedora bug
for this. The next version NetworkManager-
will bring a fix.

@Chris, you can also install the new package manually, before it is
stable. Get the packages from .

I was not so much interested in why you happened to change the method
path vs. blob. Instead I would be very much interested whether the
problem is actually fixed. Thank you!! ;-)


Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]