VLAN issues


I've been testing the bridging, bonding and VLAN functionality within NetworkManager 0.9.8 for use on a router and I think I've ran into a few bugs, test configurations attached.


Attempts to configure an ethernet port as a VLAN trunk with two sub-interfaces, one of which identifies the parent interface by connection UUID (wanted behaviour) and one which uses the device name instead. The latter works fine but the former fails with the following error:

# nmcli con up id eth2.1
Error: Connection activation failed: Failed to determine connection's virtual interface name.

If the eth2.1 configuration is present during boot, NetworkManager creates the eth2.1 device (shown by ip link) but does not configure it. syslog includes the same error and 'nmcli con status' does not show the connection.


Attempts to configure a VLAN trunk on top of a bridge, a bond and a VLAN tag interface. Much the same as the VLAN configuration in vlan.tar, except neither sub-interface can be started or is created. 'nmcli con up ...' fails with the same error message.

Any thoughts?

Daniel Collins
Junior Developer 
daniel collins smoothwall net 

Smoothwall Ltd
Phone: +44 (0­) 8701 999500

Smoothwall Limited is registered in England, Company Number: 4298247 and whose registered address is 1 John Charles Way, Leeds, LS12 6QA United Kingdom 
Any opinions stated in this message are solely those of the author.

Attachment: vlan.tar
Description: Unix tar archive

Attachment: vlan-on-vlan.tar
Description: Unix tar archive

Attachment: vlan-on-bridge.tar
Description: Unix tar archive

Attachment: vlan-on-bond.tar
Description: Unix tar archive

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]