AW: Problems with Sierra MC 8790 with older firmware revision



The following patch solves the problem for us. It works with all revisions we have available for testing

Gerald

--- mm-plugin-sierra.c~ 2012-08-29 17:02:18.000000000 +0200
+++ mm-plugin-sierra.c  2013-03-01 13:22:09.000000000 +0100
@@ -78,6 +78,9 @@
         if (strstr (response, "C885"))
             g_object_set_data (G_OBJECT (task), TAG_SIERRA_APP_PPP_OK, GUINT_TO_POINTER (TRUE));
 
+        if (strstr (response, "MC8790"))
+            g_object_set_data (G_OBJECT (task), TAG_SIERRA_APP_PPP_OK, GUINT_TO_POINTER (TRUE));
+
         /* For debugging: let users figure out if their device supports it or not */
         if (getenv ("MM_SIERRA_APP1_PPP_OK")) {
             mm_dbg ("Sierra: APP1 PPP OK '%s'", response);

-----Urspr√ľngliche Nachricht-----
Von: networkmanager-list [mailto:networkmanager-list-
bounces gnome org] Im Auftrag von Gerald Richter - ECOS
Gesendet: Montag, 25. Februar 2013 13:10
An: Dan Williams; Harald Jung
Cc: Marius Kotsbak; networkmanager-list gnome org
Betreff: AW: Problems with Sierra MC 8790 with older firmware revision

Hi Dan,

we have now tested with two MC8790 cards. One has work ever since with
modem-manger, the other didn't (as Harald reported last week).

From an usb point of view there is no difference (same product/vendor id
etc.).

The only difference is, that the card that isn't working reports Revision
K1_0_3_0AP, while the one that is working reports K1_1_1_9AP.

Running with

MM_SIERRA_APP1_PPP_OK=1 /modem-manager --debug

Both cards are working correctly and both use ttyUSB4 for pppd (while the
one that worked before uses ttyUSB3 without that setting).

So as far as we can test, it's safe to always use ttyUSB4 on MC8790.

Could you please let us know how to tell modem-manager to always use this
setting for MC8790

Thanks & Regards

Gerald



-----Urspr√ľngliche Nachricht-----
Von: Dan Williams [mailto:dcbw redhat com]
Gesendet: Freitag, 22. Februar 2013 04:57
An: Harald Jung
Cc: Marius Kotsbak; networkmanager-list gnome org
Betreff: Re: Problems with Sierra MC 8790 after kernel upgrade to
3.7.x

On Thu, 2013-02-21 at 19:36 +0100, Harald Jung wrote:
Hi,

after a coldstart your hint worked.
Is there a possibility to pass manage this by udev?
modem-manager uses an enviroment variable and is triggered itself by
dbus.
So it seems to be difficult in the first place.

The environment variable is only there for testing.  Once we have a
positive test, we can tell ModemManager that the 8790 is OK to do this for
everyone.

Dan


Harald

Am 18.02.2013 12:24, schrieb Harald Jung:
the output looks a bit different but i wasn't able to establish a
connection :(

modem-manager[6820]: <debug> [mm-manager.c:859]
device_added():
(net/ppp0): could not get port's parent device
modem-manager[6820]: <debug> [mm-at-serial-port.c:334]
debug_log():
(ttyUSB3): <-- '<CR><LF>+CIEV: 1,3<CR><LF>'
modem-manager[6820]: <debug> [mm-at-serial-port.c:334]
debug_log():
(ttyUSB3): <-- '<CR><LF>+CIEV: 7,0<CR><LF>'
modem-manager[6820]: <debug> [mm-serial-port.c:697]
data_available():
(ttyUSB4) unexpected port hangup!

Harald

Am 15.02.2013 22:07, schrieb Dan Williams:
On Fri, 2013-02-15 at 09:26 +0100, Harald Jung wrote:
I've cleaned up to log, because i have no access to the notebook
at the moment.
ipv6 should be deactived and is not activated in the config.
Once you have access to the notebook again, can you stop MM the
normal
way:

mv /usr/sbin/modem-manager /
killall -TERM modem-manager

and then run MM like this?

MM_SIERRA_APP1_PPP_OK=1 /modem-manager --debug

and attempt a connection?  Older Sierra devices allow PPP on the
APP1 port (ttyUSB4 on your device) but unfortunately we have to
whitelist that.  It's actually impossible to test which tty
accepts PPP on most Sierra devices, so we really have no idea.
For examply, my C885 and
USB306 allow it, but none of my (four) 8775s or my 8781 allows it.

Dan

_______________________________________________
networkmanager-list mailing list
networkmanager-list gnome org
https://mail.gnome.org/mailman/listinfo/networkmanager-list




_______________________________________________
networkmanager-list mailing list
networkmanager-list gnome org
https://mail.gnome.org/mailman/listinfo/networkmanager-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]