RE: NetworkManager Settings and D-Bus


Thank you for the reply.  I did finally figure that had to be the case and
have been working with that in mind.   What is strange though is both the
code I am trying to fix and the example that is in the e-mail give me the
same error.  It looks like the example from NetowrkManager is using the 0.9
API which makes it even more confusing as to why I get the error when
running that code.  The call to ActivateConnection in this example code uses
6 parameters but the API only shows 3 now instead of the 4 that 0.8 had.  So
I am totally confused about this.  I am sure it is something simple but at
this point I don't get it.  If I am providing too many parameters I would
think the error would be different than it telling me that there are too few

I am assuming here though that this example code from NetworkManager has
been updated to the 0.9 API.  


-----Original Message-----
From: david e narvaez gmail com [mailto:david e narvaez gmail com] On Behalf
Of David Narvaez
Sent: Monday, July 25, 2011 4:04 PM
To: Bob Bader
Cc: networkmanager-list gnome org
Subject: Re: NetworkManager Settings and D-Bus

On Mon, Jul 25, 2011 at 2:08 PM, Bob Bader <lists dbent net> wrote:
> I am having a problem with my python script that does a IP refresh for our
product.  When I run this script in Fedora 12 it works fine but when I run
it in Fedora 15 it fails.  I have been told it works in Fedora 14 also.  The
digging I did I found a few things but could not get ActivateConnection to

Hi, I haven't looked into the code but please note that Fedora 15 uses
Network Manager 0.9 which has a different D-Bus API, and is
incompatible with previous versions of NM, so that may be affecting
your code.

David E. Narvaez

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]