Re: NM-0.7.1rc1 fails to build with --as-needed

On Fri, Feb 27, 2009 at 3:14 AM, Dan Williams <dcbw redhat com> wrote:
> Odd; what gcc version?

Oops, forgot to mention.
gcc (Gentoo 4.3.3 p1.0, pie-10.1.5) 4.3.3
gcc (GCC) 4.2.4 (Gentoo 4.2.4-r1 p1.1)
Both fail with the same error.

> Does the following patch work better?

No. It gives the same error.

x86_64-pc-linux-gnu-gcc -O2 -march=core2 -pipe -Wl,-O1 -Wl,-O1
-Wl,--sort-common -Wl,--as-needed -o .libs/test-keyfile
-L/usr/lib64/nss -L/usr/lib64/nspr
/usr/lib64/ /usr/lib64/ -luuid -lssl3
-lsmime3 -lnssutil3 -lnss3 -lplds4 -lplc4 -lnspr4 -ldl
/usr/lib64/ -lpthread -lrt
/usr/lib64/ /usr/lib64/
In function `write_connection':
writer.c:(.text+0xc78): undefined reference to `nm_settings_error_quark'
writer.c:(.text+0xcf8): undefined reference to `nm_settings_error_quark'
collect2: ld returned 1 exit status
make[6]: *** [test-keyfile] Error 1

Victor Ashirov

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]