nm 0.7 doesn't connect to wired


I'm running NM 0.7 from trunk and connecting with the wired interface
worked before when i was connecting my laptop to my router.

Now I'm currently visiting my parents and have my laptop connected to
their DSL modem directly and have updated NM recently to the latest
version, so maybe something is broken there.

Anyway, I'm using rp-pppoe to connect to the dsl modem, since NM's pppoe
connection editor is not yet finished and that works fine.
However, the nm-applet tries to establish the connection on the wired
device, but fails to get a network address and gets back to disconnected
The connection is there, the interface is there, but it doesn't work
with NM.

I don't have specified an IP adress and don't bring up the device with
Arch's network script, but let it be handled by NM instead.

Any Ideas why NM can't establish the connection correctly? Is something
wrong with dhcp or what?

btw, when I run nm-tool, I get this segfault:

> $ nm-tool 
> NetworkManager Tool
> State: disconnected
> (process:8359): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `NMDevice'
> ** (process:8359): CRITICAL **: nm_device_get_state: assertion `NM_IS_DEVICE (device)' failed
> ** (process:8359): CRITICAL **: nm_device_get_iface: assertion `NM_IS_DEVICE (device)' failed
> - Device: (null) ----------------------------------------------------------------
> ** (process:8359): CRITICAL **: nm_device_get_driver: assertion `NM_IS_DEVICE (device)' failed
>   Driver:            (unknown)
>   Active:            no
> ** (process:8359): CRITICAL **: nm_device_get_capabilities: assertion `NM_IS_DEVICE (device)' failed
>   Capabilities:
>     Supported:       no
> Segmentation fault

could this be causing the problem?

I don't have a wireless network here atm, but that worked fine the last time I tried (3 days ago or so).
Unfortunately, the iwl3945 never worked for ad-hoc for me, so I can't try that either.
The network is never created, NM always gets back to disconnected state. That's another issue,
but maybe you can tell me, if it _should_ be able to create a new wireless network with that driver in
in general ;)


Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]