Re: NM stopped using local caching nameserver?

Quoting Dan Williams <dcbw redhat com>:

On Tue, 2007-11-13 at 10:12 -0500, Derek Atkins wrote:
I tracked this down some..  It appears part of the issue is a
race condition between named and dbus.  The startup sequence
has named start first, and then dbus...  but then named doesn't
connect to dbus properly.  If I RESTART named then everything
appears to work okay.

I suspect the problem here is that named doesn't retry to connect
to dbus if it fails to connect on startup.

Would this be a named bug?

Well, probably an init ordering between named and dbus initscripts,


I tried various re-orderings and something or other seemed to fail
when I changed the order.  I fixed it by adding a named restart
to rc.local.  Annoying, but it works.  Ideally, named should
just try to reconnect to dbus.

      Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
      Member, MIT Student Information Processing Board  (SIPB)
      URL:    PP-ASEL-IA     N1NWH
      warlord MIT EDU                        PGP key available

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]