Re: Everything works, except dhclient

On Tue, 2006-02-07 at 00:32 -0700, Nix N. Nix wrote:
> Hi!
> I finally got NM to the point where clicking on the "Wired Network"
> causes dhclient to run. Unfortunately, dhclient fails to grab an IP, yet
> running dhclient on the same interface manually grabs an IP almost
> immediately.
> Also, once I run dhclient manually on my interface and click on
> "Connection Information", the information displayed therein does not
> reflect the actual network configuration.
> Here's the dhclient command line executed by (I presume) dhcdbd:
> /sbin/dhclient -1 -lf /var/lib/dhclient/dhclient-eth1.leases
> -pf /var/run/ -q -e dhc_dbus=31 -x -d eth1
> I ran man dhclient and, apparently, it doesn't even have a "-e"
> switch ...

Is this on Fedora Core?  Or another distro?

dhclient needs a patch or two, as does your dhclient-script, to work
with dhcdbd and NetworkManager.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]