Re: A couple of minor issues with NM

On 12/22/06, Timothy Murphy <tim birdsnest maths tcd ie> wrote:

It always tries to connect to a network I very seldom use.

Are both open network or is one WEP and the other open?  I /think/
that Network Manager will not automatically connect to an unencrypted
network but I am not certain since I rarely use an unencrypted
networks since I got my Aircard.

Incidentally, where does it store "profiles" or indeed any information?
Is it available to the user?

It is under gconf:

A full profile manager is planned for 0.7

I'm using an Orinoco PCMCIA Gold Card on my laptop,
and Linksys WRT54GL as an Access Point on my desktop.
I might say that this works perfectly under Windows.
Sadly, I find Linux WiFi rather a mess, to put it mildly.

Don't blame Linux for that, blame the hardware vendors who don't
support it... Though the Orinoco card should work fine, I used one for
awhile and never experienced the problems you describe.   Do you have
the same issues when using the normal Network-Admin tool?

Have you checked your systems logs to see if it reports why the
association is being stopped?

There seem to be files and programs all over the place
which might or might not have some relevance.

That is a distro issue (Though I run Ubuntu have absolutely no idea
what you are talking about especially since your driver is in the
kernel...) and probably has no relevance

> > 5) Not really an NM question,
> > but I have a Linksys WRT54GL running dd-wrt .
> > Does anyone know how to install a WEP key on it?
> > [I know WEP is not very secure;
> > but it is the only encryption my PCMCIA card understands.]
> Yes, go to Wireless, then wireless security and select WEP

Thanks, I tried that but unfortunately it seemed to have
a disastrous effect on NM.
Basically, my WEP key was never accepted.
(It does not accept the WEP key on my old network either,
which works perfectly with Windows.)

What is more, after failing to accept my key
NM said it could not find any wireless networks,
where previously it saw two of them.

Has anyone else had problems getting NM to accept a WEP key?

No, but is it a hex or ascii key?   I just tried it on my system and I
was able to enter the passphrase and connect right away.

I'm pretty critical of NetworkManager at the moment.
It seems to me it tries to be too clever
(a common fault with Linux applications)
instead of being satisfied to do one thing, and do that properly,
as Ken Thompson recommended.

Then use Network-Admin or wifi-radar....  Network-Manager is not the
only tool available to manage wireless networks.

Network Manager is doing ONE thing and that is manage your networks.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]