Re: Linksys/Dell SRX400 problem with WPA-PSK/TKIP

On Fri, 18 Aug 2006, Darren Albers wrote:

It is certainly odd that it worked with WPA/AES and not with WPA/TKIP.

Can you try creating a wpa_supplicant.conf like this:
     ssid="Enteryour SSID Here"

And then try one of the two commands to bring up WPA_Supplicant:
wpa_supplicant -d -c/path/to/wpa_supplicant.conf -ieth1 -Dwext
wpa_supplicant -d -c/path/to/wpa_supplicant.conf -ieth1 -Dndis

Replace eth1 with your interface name.

Then bring up the interface normally ie ifup eth1

If it connects fine with -Dwext then something wierd is happening
between NetworkManager and WPA_Supplicant.

I will try this the next time I go into the office.

I'm getting the gradual idea that the right way to debug NM problems is
to try to make wpa_supplicant work first to see if the problem is there
or in NM per se?  If so I guess I'll have to learn to drive
wpa_supplicant directly...

If it only connects via -Dndis then you are running a version of
NDISWrapper that doesn't support WEXT (Though this is unlikely since
WPA/AES worked...) and you will need to update NDISWrapper.

I'm not using ndis -- I have a native ipw2200 interface configured as

alias eth1 ipw2200
options ipw2200 hwcrypto=0 associate=0

in /etc/modprobe.conf as was suggested once on list (to keep the
hardware out of the interaction picture?).  This is FC5, so the driver
and kernel and so on are pretty much up to date.

Thanks for the suggestion.


Robert G. Brown	             
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb phy duke edu

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]