Re: Mime-type detection and GLabels application


I did manage to solve the problem in the meantime. I have made a file /usr/share/mime/packages/glabels.xml as:

<?xml version="1.0" encoding="UTF-8"?>
<mime-info xmlns="";>
    <mime-type type="application/x-glabels">
        <comment xml:lang="en">Glabels document</comment>
        <glob pattern="*.glabels" />

after which I ran "update-mime-database /usr/share/mime" as root.

After restarting nautilus the mime type worked as expected.

The problem here is that I needed to be root to do it, which is at least sub-optimal.

I'm not quite sure if I need to file a bug report on nautilus, gnome-vfs, glabels or freedesktop's shared-mime-info.


Alexander Larsson wrote:
On Mon, 2004-06-28 at 11:20, René Seindal wrote:


I use the glabels application to print out adressing labels, but after I upgraded to Gnome 2.6, I can no longer launch glabels by clicking on a .glabels file. It is being classified as a application/x-gzip file and I'm only offered file-roller as a possible application.

I have .glabels file registered as application/x-glabels in "File Types and Programs", with the glabels application as default, but it is apparently being ignored.

How do I persuade nautilus to launch the application of my choice on these files?

Hmm, this is due to the change in the mime type system to the new system. Unfortunately the file types and programs app
creates the old-style mime types. We're working on fixing this.

Alexander Larsson Red Hat, Inc alexl redhat com alla lysator liu se He's a lonely Catholic gangster whom everyone believes is mad. She's a supernatural green-skinned snake charmer in the wrong place at the wrong time. They fight crime!

René Seindal (rene seindal dk)
Seindal Consult

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]