Some problems with Nautilus 2.0.7


I have some problems with Nautilus but, as I have very few experience with 
GNOME, I don't know if that's bugs and if they come from Nautilus or any 
other software.

As a web developer, I need to work on server-side PHP scripts. I've been used 
to opening konqueror and typing ftp://login server, then entering my password 
and clicking on the file I wanted to edit. It opened it in -say- kwrite and I 
could save it directly on the server (without downloading it).

I tried to do the same using Nautilus and here's how it acted:

First, typing ftp://login server didn't work: I had to enter 
login:password server as it never asked me for my password and simply failed 
to connect.

So, I typed ftp://bob:foo server and the content of /home/bob (on the server) 
was displayed.

Then, I clicked on a folder (located in /home/bob on the server) but it 
failed, telling me that the folder didn't exist. Then, the folder 

I then tried to type ftp://bob:foo server/home/bob and I could click on 
subfolders this time.

Now, I wanted to open somefile.php but double-clicking on it told me that 
gedit couldn't access files located on ftp locations.

Well... as you see, I could'nt manage to do what I wanted.

Could you tell me more about those problems ? Did I miss something ? Are those 
bugs known ? Do I need to upgrade some library ?

The second strange thing I noticed is that file-association seemed to be very 
badly configured. Lots of common file formats didn't have any program 
associated to them. I changed that manually so I can't remember which formats 
exaclty. But I remember that the default action for the text files was to 
open them with nautilus. I find it stupid as, most of the times, I want to 
edit a files, not just read it.

I think the best way is to do KDE-3.1's way: if a format is mostly read-only 
(images, HTML files, sounds, SVG, videos...) open them within Nautilus, and 
if the file is mostly read-write (text files, office documents...), open them 
with an external application. 

Thanks for reading my email and answering me if I missed something or if I 
need to upgrade my system.

PS: I tested it on Mandrake 9.0 and Red Hat 8.0 only.

Julien Olivier

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]