Re: [Nautilus-list] two keynav/a11y patches



On 19 Apr 2002, Dave Camp wrote:

> The first patch makes the icon container popup a menu on shift-f10.

I don't like the fact that the menu pops up in a "random" place. (Where 
the last button press event was or something.) Can you make it always pop 
up over the first selected icon, or in the top left corner of the canvas 
if no items are selected.
 
> The second patch makes the zoom control show its focus, gives it some
> keybindings, and adds AtkValue and AtkAction interfaces to it

Please use <libgnome/gnome-i18n.h> instead of <bonobo/bonobo-i18n.h>, as 
that is what the rest of nautilus uses.

We should probably make up a better name instead of:
 N_("Show the contents at optimal size")
What about "Try to fit in window". Hmm. That sounds dorky too. Ideas?

+	if ((accessible = eel_accessibility_get_atk_object (widget))) {
+		return accessible;
+	}
Don't assign in the comparison.

+	gtk_binding_entry_add_signal (binding_set, 
+				      GDK_equal, 0, 
+				      "change_value",
+				      1, GTK_TYPE_SCROLL_TYPE,
+				      GTK_SCROLL_STEP_UP);
This should be GDK_plus, not GDK_equal. And you're missing the right 
binding for GDK_equal.

In nautilus_zoom_control_accessible_do_action, 
nautilus_zoom_control_accessible_action_get_description and 
nautilus_zoom_control_accessible_action_get_name. Check for valid range 
for i before using it (we want at least some warning spew if it's wrong).

What happens if you use 
nautilus_zoom_control_accessible_set_current_value() to set the zoom to an 
irregular zoom level (one not normally in the zoom widget)? Does it work?

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 Alexander Larsson                                            Red Hat, Inc 
                   alexl redhat com    alla lysator liu se 
He's a genetically engineered moralistic firefighter moving from town to town, 
helping folk in trouble. She's an elegant goth stripper with a birthmark 
shaped like Liberty's torch. They fight crime! 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]