[Muine] Muine 0.6.1 problem

I had no trouble compiling mono 0.31, gtk-sharp 0.18, and some gtk# apps
like f-spot or Muine 0.5.3. 
Now, I'm running into troubles trying to compile Muine 0.6.1. 
Compilation of mono 0.91 and gtk-sharp 0.91.1 went without problems,
also compilation of Muine didn't get me any errors. 
But, now, when trying to start Muine, I get this error: 
                      [root localhost src]# muine 
Compat mode: the request from /usr/lib/glib-sharp.dll to load System was
             remapped (http://www.go-mono.com/remap.html) 
           Unhandled Exception: System.DllNotFoundException:
                in <0x00053> (wrapper managed-to-native)
                Gtk.IconFactory:gtk_icon_factory_new () 
                 in <0x0001c> Gtk.IconFactory:.ctor () 
                 in <0x00053> StockIcons:Initialize () 
                  in <0x00125> Muine:.ctor (string[]) 
                  in <0x00056> Muine:Main (string[]) 

Anyone has any hint what is wrong? 
I've tried to delete all mono and gtk-sharp files and compiled again,
but no luck.
I've checked out muine.exe.config and it it is in /usr/lib/muine and it
looks like this:
  <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
  <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
  <dllmap dll="libmuine" target="/usr/lib/muine/libmuine.so"/>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]