Shift - Cursor keys


I've recently been running into an issue with MC. I've always used MC by logging in via Putty SSH and then starting MC. This has always worked fine.

Recently however, MC has started to interpet cursor keys in a different way, to be precise, it no longer recognizes shift-cursor keys as a way to select items. Instead, it just puts "B" and "A" on the command line when pressing shift-up or shift-down on the keyboard. Using arrow keys without shift work fine.

I've tried changing the putty configurations, setting the application and normal mode for the keypad, that didnt work.

I've tried logging in from ssh on a Mac, that did work. When logged in via ssh on the Mac I can shift select items.

This is my config;
rider ruby:~$ mc -V
GNU Midnight Commander 4.8.1
Built with GLib 2.31.20
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Any suggestions?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]