Strange VFS problem

I''ve hit a very strange problem with MCs VFS handling. I've not yet
reported it as a bug, since I'm having some difficulty isolating it,
and I'm far from sure how reproducable it will be.

I use Synbak ( for
backups. For my laptop, I use it to create a gzipped-tar on a USB
drive. I've been using it for quite a while with no problems.

I've just put a new USB drive in place for backups - the 80 GB one I
was using is getting pretty full, so I've put a 250 GB Seagate
Momentus into a caddy and I've been using it for a month or so.

After redoing the backup config, I was having a look at a recent
backup to make sure everything had gone through as it should. A fairly
large file - 2.2 GB compressed to around 800 MB archive (mainly due to
the bulk of my email). As usual, I was using MC for the task.

I attempted to view a text file in the archive. Using F3 did nothing.
I then tried to extract the file from the archive to see what might be
causing a problem. At which point I got a pop up from MC saying:

Cannot read source file "/media/DataTrans/backup/tigger/announce"
Input/output error (5)

I've tried everything I can think of to isolate the problem. I've used
versions of MC ranging from 4.0.7 to, with identical results.
I've used different versions of tar and gzip. I've tried creating the
archive on the laptop's internal hard drive, just to be sure that
there isn't some form of file corruption occuring during the transfer
to the USB drive. I tried modifiying the 'announce' file (its plain
text). I've run checks on the file systems of both the internal drive
and the USB drive.

None of these things have made any difference - MC will not open or
extract the file from the .tar.gz. There are also several others that
show the same problem in the archive.

Synbak does basic error trapping, so there are no errors being
returned from either tar or gzip when the archive is created. To
further check, I've manually extracted every file in the archive
(which worked without any problems) and compared the extracted files
with the originals - no difference. I've also used two archive
handling packages - Xarchiver and File Roller, both of which can
extract the file, and both of which report no problems with it, or any
of the other files in the archive.

As things stand, most of the files in my backup work fine with MC, but
there are a few (I've not tried every text file in the archive yet)
which all exhibit the same problem - MC wil not open them and cannot
extract them.

I will try creating a smaller archive with some of the problem files
and see if that makes any difference, but I'm not sure how else to
reproduce it.

Any ideas? Anyone else seen a VFS problem of this sort?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]