alternative key-binding to "C-Shift-Enter" for use in xterms?

I've only just signed up for the mc gnome org mailing list. But
I've used mc as my file manager in any Linux I'm using for years. 
And I have to say, I wouldn't want to be without it. KUDOS to 
the authors and maintainers!

But I've almost always been disappointed by the fact that in xterm and/or
konsole, I've been unable to find a key binding that will copy the
full path name of the currently selected file to the command line.
(the only exception I've found to that is with Sabayon Linux {which is
based on gentoo...}) in all the other Linux {usually under kde} I've tried
since fedora core 1, both C-Enter and C-Shift-Enter acted like I hadn't
pressed a modifier key. Though usually Alt-Enter did work. But that's not
as useful as C-Shift-Enter in building a command line affecting multiple
files in more than one directory...

Unless I'm using Sabayon or am actually in a console, I wind up
doing something like positioning the cursor in the panel displaying the
directory with the fewest applicable files. Then doing something like
"X=$(pwd)Enter" and typing the command using "$A/Alt-Enter" to effectively
copy the pathnames from that directory and just "Alt-Enter" (or Esc Enter)
to copy the filenames from the other directory. Then if I make sure I'm
in the other directory when I hit enter, it generally works. But that's a
real pain...

Does anyone know an easier way to do this?????????? 

AND/or does anyone know what is so different with Sabayon that the 
C-Shift-Enter binding works in X on it and not in the other distro's???

I'm currently using the mc I get with apt-get and/or emerge:

mc 4.6.2-pre1 in: Elive development ver 1.9.51 (based on debian lenny)
Where the C-Shift-Enter key binding fails when using: Konsole 1.6.6
(allegedly: using kde 3.5.10) (Using e17) kde not fully installed)
or using: rxvt-unicode, version 9.05

mc 4.6.2-pre1 in: Kubuntu Jaunty
Where the C-Shift-Enter key binding fails when using: Konsole 2.2.2 
(using kde 4.2.2 ) or using: xterm 241

And also:

mc 4.6.2-pre1 in: Sabayon 4.2 (the kde/64bit version)
Where the C-Shift-Enter key binding WORKS when using: Konsole 2.2.3 
(using kde 4.2.4 ) or using: xterm 243

I do note that the konsole and xterms versions are higher in this Sabayon
installation. But I don't think that's really relevant because It has
"just worked" for me in Sabayon since Sabayon 3.5f (Using kde 3.x) 

|  ~^~   ~^~
|  <?>   <?>             Joe (theWordy) Philbrook
|      ^                      J(tWdy)P
|    \___/                 <<jtwdyp ttlc net>>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]