Re: crash when editing from a search in certain conditions

On Thu, 7 Sep 2006, wwp wrote:

On Thu, 7 Sep 2006 11:47:55 +0300 (EEST) Pavel Tsekov <ptsekov gmx net> wrote:

On Thu, 7 Sep 2006, Pavel Tsekov wrote:

On Thu, 7 Sep 2006, wwp wrote:

Bug can't be reproduced:
- with FC5's mc (IIRC, 20060812-18 snapshot + FC patches)
- with 20060307-16 snapshot (-O2)
- current CVS (-O2)

bug can be reproduced (100% w/ the scenario above):
- with 20060812-18 snapshot, with -O0 or -O2

Strange. The latest changes to the editor were made on
Aug 2. Maybe the theory that some memory is being
used incorrectly and this manifests in the crash you are
experiencing is correct. I will build from the snapshot
sources and see what's going on.

Using 2006-08-12-18 I still cannot reproduce.

Well.. I made all mc builds using the same ./configure + make (same CFLAGS by

I tried both the binary rpm and built myself from the source tarball but
still it doesn't crash.

default). I don't see why this crash happens w/ a specific snapshot. If you

Well, this kind of errors are hard to track down. It's a pity that
I cannot get it to crash on my mashine.

don't decide to ignore this crash until you get another report, feel free to
request for more test/info.

If I am right the cause for the crash happens earlier so the backtrace is
of no use. Maybe running MC under some kind of memory error debugging
tool like valgrind might give some interesting info. You can send me a
strace of MC too.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]