[BUG] ? mc hangs when $DISPLAY set

Hi folks,

I've got some strange problem with mc, I already hat a long 
time ago, but disappeared magically and now is back:

mc keyboard input is broken - seems like it has Alt-Gr is pressed 
continously ... completely unusable. 

It happened only on one machine, which is accessed only via ssh.
Doesn't matter from which machine I tried. The other machines
do not have such problems, even when connecting through sevel ssh's
from one to another. Also ssh'in from an xterm (on another machine)
worked without problems.

So I strace'd mc on several machines to compare mc's actions between 
working and non working. I found out that on working machines it gets 
in clean keystrokes via fd 3. On the broken one, the keystrokes come 
at fd 4, but fd 3 brings in a lot of bytes I could't interpretate. 
lsof showed by this fd 3 as an socket connected to the (remote) 

Unsetting $DISPLAY helped.

Obviously we've got a problem, when mc sees an X display (and connects
to it), but doesn't run in an xterm.

What exactly is this X connection for ?

 Enrico Weigelt    ==   metux IT service - http://www.metux.de/
 Please visit the OpenSource QM Taskforce:
 Patches / Fixes for a lot dozens of packages in dozens of versions:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]